package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mi)(?:[0-9A-F]{2}[:]){5}(?:[0-9A-F]{2})`)
var str = `ff:ff:ff:ff:ff:ff <-> 00:1e:68:51:4f:a9 1 42 0 0 1 42 288.470566000 0.0000`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}