$re = '/(?:[0-9A-F]{2}[:]){5}(?:[0-9A-F]{2})/mi';
$str = 'ff:ff:ff:ff:ff:ff <-> 00:1e:68:51:4f:a9 1 42 0 0 1 42 288.470566000 0.0000';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);