import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "((\\/\\*+)(\\*|\\s)*(.*\\**)(\\*|\\s)*(\\*+\\/))";
final String string = "/*basic comment*/\n\n\n"
+ "console.log('turtle');\n\n\n"
+ "/*********************\n"
+ "Fancy liney comment\n"
+ "*********************/\n\n\n"
+ "console.log('turtle');\n\n\n"
+ "/****long basic comment ****/\n\n\n"
+ "console.log('turtle');\n\n\n"
+ "/*\n"
+ " *\n"
+ " * Oh look, it's one of these... great.\n"
+ " *\n"
+ " */";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}