import re
regex = re.compile(r"((\/\*+)(\*|\s)*(.*\**)(\*|\s)*(\*+\/))")
test_str = ("/*basic comment*/\n\n\n"
"console.log('turtle');\n\n\n"
"/*********************\n"
"Fancy liney comment\n"
"*********************/\n\n\n"
"console.log('turtle');\n\n\n"
"/****long basic comment ****/\n\n\n"
"console.log('turtle');\n\n\n"
"/*\n"
" *\n"
" * Oh look, it's one of these... great.\n"
" *\n"
" */")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")