$re = '/((\/\*+)(\*|\s)*(.*\**)(\*|\s)*(\*+\/))/';
$str = '/*basic comment*/
console.log(\'turtle\');
/*********************
Fancy liney comment
*********************/
console.log(\'turtle\');
/****long basic comment ****/
console.log(\'turtle\');
/*
*
* Oh look, it\'s one of these... great.
*
*/';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);