#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(.*OLD_SQ.*)"
Local $sString = "/*!40101 SET @OLD_SQL_MODE=@@SQL_MODE, SQL_MODE='' */;" & @CRLF & _
"/*!40111 SET @OLD_SQL_NOTES=@@SQL_NOTES, SQL_NOTES=0 */;" & @CRLF & _
"DROP TABLE IF EXISTS `action`;" & @CRLF & _
"/*!40101 SET @saved_cs_client = @@character_set_client */;" & @CRLF & _
"/*!40101 SET character_set_client = utf8 */;" & @CRLF & _
"CREATE TABLE `action` (" & @CRLF & _
" `id` tinyint(4) NOT NULL," & @CRLF & _
" PRIMARY KEY (`id`)" & @CRLF & _
") ENGINE=InnoDB DEFAULT CHARSET=utf8;" & @CRLF & _
"/*!40101 SET character_set_client = @saved_cs_client */;" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"/*!40101 SET SQL_MODE=@OLD_SQL_MODE */;" & @CRLF & _
"/*!40111 SET SQL_NOTES=@OLD_SQL_NOTES */;"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")