# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(.*OLD_SQ.*)"
test_str = ("/*!40101 SET @OLD_SQL_MODE=@@SQL_MODE, SQL_MODE='' */;\n"
"/*!40111 SET @OLD_SQL_NOTES=@@SQL_NOTES, SQL_NOTES=0 */;\n"
"DROP TABLE IF EXISTS `action`;\n"
"/*!40101 SET @saved_cs_client = @@character_set_client */;\n"
"/*!40101 SET character_set_client = utf8 */;\n"
"CREATE TABLE `action` (\n"
" `id` tinyint(4) NOT NULL,\n"
" PRIMARY KEY (`id`)\n"
") ENGINE=InnoDB DEFAULT CHARSET=utf8;\n"
"/*!40101 SET character_set_client = @saved_cs_client */;\n\n\n"
"/*!40101 SET SQL_MODE=@OLD_SQL_MODE */;\n"
"/*!40111 SET SQL_NOTES=@OLD_SQL_NOTES */;")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.