import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(.*OLD_SQ.*)";
final String string = "/*!40101 SET @OLD_SQL_MODE=@@SQL_MODE, SQL_MODE='' */;\n"
+ "/*!40111 SET @OLD_SQL_NOTES=@@SQL_NOTES, SQL_NOTES=0 */;\n"
+ "DROP TABLE IF EXISTS `action`;\n"
+ "/*!40101 SET @saved_cs_client = @@character_set_client */;\n"
+ "/*!40101 SET character_set_client = utf8 */;\n"
+ "CREATE TABLE `action` (\n"
+ " `id` tinyint(4) NOT NULL,\n"
+ " PRIMARY KEY (`id`)\n"
+ ") ENGINE=InnoDB DEFAULT CHARSET=utf8;\n"
+ "/*!40101 SET character_set_client = @saved_cs_client */;\n\n\n"
+ "/*!40101 SET SQL_MODE=@OLD_SQL_MODE */;\n"
+ "/*!40111 SET SQL_NOTES=@OLD_SQL_NOTES */;";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}