# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\b(Information)\b([\S\s]*?)\b(Email)\b//;t' <<< "Contact Information
lori
Email: customer@yahoo.com
Phone: (xxx) xxx-xxxx
"