import re
regex = re.compile(r"\b(Information)\b([\S\s]*?)\b(Email)\b")
test_str = ("Contact Information \n"
"lori \n"
"Email: customer@yahoo.com \n\n"
"Phone: (xxx) xxx-xxxx\n")
subst = ""
result = regex.sub(subst, test_str, count=1)
if result:
print(result)