using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"((^|\.)((25[0-5]_*)|(2[0-4]\d_*)|(1\d\d_*)|([1-9]?\d_*))){4}_*$";
string input = @"192.168.88.1__
192.168.88_.200
192.16_.88_.2__
192.168.88.2";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}