$re = '/((^|\.)((25[0-5]_*)|(2[0-4]\d_*)|(1\d\d_*)|([1-9]?\d_*))){4}_*$/m';
$str = '192.168.88.1__
192.168.88_.200
192.16_.88_.2__
192.168.88.2';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);