re = /((^|\.)((25[0-5]_*)|(2[0-4]\d_*)|(1\d\d_*)|([1-9]?\d_*))){4}_*$/m
str = '192.168.88.1__
192.168.88_.200
192.16_.88_.2__
192.168.88.2'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end