import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?!CT)\\d{2}";
final String string = "CT27-ED R\n"
+ "CT27-CD N\n"
+ "CT40-ED R\n"
+ "CT24-CD R\n"
+ "Feeder\n"
+ "Bolter Boom";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}