import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?!_)\\w+(?:[.-]\\w+)*(?<!_)@[^\\W_]+(?>[.-]?\\w*[^\\W_])*\\.[^\\W_]{2,}$";
final String string = "jasmin-martinez@tester.co\n"
+ "lisabrown.king@tester.co\n"
+ "jasmin.martinez@tester.co.rolisa-brown.king@tester.co.ro";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}