re = /^(?!_)\w+(?:[.-]\w+)*(?<!_)@[^\W_]+(?>[.-]?\w*[^\W_])*\.[^\W_]{2,}$/m
str = 'jasmin-martinez@tester.co
lisabrown.king@tester.co
jasmin.martinez@tester.co.rolisa-brown.king@tester.co.ro'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end