package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)(?:(\d{1,2})(?:th|nd|rd).* ([a-z]{3})[a-z]*|([a-z]{3})[a-z]* (\d{1,2})),\s*(\d{4})`)
var str = `this amendment of lease, made and entered as of the 10th day of august, 2016, by and between john doe and jane smith
this agreement, made and entered as of May 1, 2016, between john doe and jane smith`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}