re = /(?:(\d{1,2})(?:th|nd|rd).* ([a-z]{3})[a-z]*|([a-z]{3})[a-z]* (\d{1,2})),\s*(\d{4})/i
str = 'this amendment of lease, made and entered as of the 10th day of august, 2016, by and between john doe and jane smith
this agreement, made and entered as of May 1, 2016, between john doe and jane smith'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end