import re
regex = re.compile(r"(?:(\d{1,2})(?:th|nd|rd).* ([a-z]{3})[a-z]*|([a-z]{3})[a-z]* (\d{1,2})),\s*(\d{4})", flags=re.IGNORECASE)
test_str = ("this amendment of lease, made and entered as of the 10th day of august, 2016, by and between john doe and jane smith\n\n"
"this agreement, made and entered as of May 1, 2016, between john doe and jane smith")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")