using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\w+|\[([\w\s]+)\]";
string input = @"dyson [salisbury matheson beaumont] clarke [carstairs morden] vaughan";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}