re = /\w+|\[([\w\s]+)\]/
str = 'dyson [salisbury matheson beaumont] clarke [carstairs morden] vaughan'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end