#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(.+?)(\s)([A-Z].[A-Z].,)(\s)(.+?)(\s)([A-Z].[A-Z].,)(\s)(.+?)(\s)([A-Z].[A-Z].)(\s)(and)(\s)(.+?)(\s)([A-Z].[A-Z].)"
Local $sString = "Blois J.L., Zarnetske P.L., Fitzpatrick M.C. and Finnegan S.B."
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)