re = /(.+?)(\s)([A-Z].[A-Z].,)(\s)(.+?)(\s)([A-Z].[A-Z].,)(\s)(.+?)(\s)([A-Z].[A-Z].)(\s)(and)(\s)(.+?)(\s)([A-Z].[A-Z].)/
str = 'Blois J.L., Zarnetske P.L., Fitzpatrick M.C. and Finnegan S.B.'
subst = ''
result = str.sub(re, subst)
# Print the result of the substitution
puts result