const regex = /^(?=.{8,}$)(?:[^A-Z\n]*[A-Z][^A-Z\n]*|(?:[^A-Z\n]*[A-Z]){6}.*)$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?=.{8,}$)(?:[^A-Z\\n]*[A-Z][^A-Z\\n]*|(?:[^A-Z\\n]*[A-Z]){6}.*)$', 'gm')
const str = `AAAAAAaa
AAaaAAaaAVA
Aaaaaaaa
AAAAAAaa
AAaaaaaa `;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}