re = /^(?=.{8,}$)(?:[^A-Z\n]*[A-Z][^A-Z\n]*|(?:[^A-Z\n]*[A-Z]){6}.*)$/m
str = 'AAAAAAaa
AAaaAAaaAVA
Aaaaaaaa
AAAAAAaa
AAaaaaaa '
# Print the match result
str.scan(re) do |match|
puts match.to_s
end