#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mx)^ # String start" & @CRLF & _
" (?=.{8,}$) # 8 or more characters other than a newline" & @CRLF & _
" (?:" & @CRLF & _
" [^A-Z\n]*[A-Z][^A-Z\n]* # a string with 1 uppercase letter only" & @CRLF & _
" | # or..." & @CRLF & _
" (?:[^A-Z\n]*[A-Z]){6} # 6 occ. of 0+ chars other than uppercase letters followed with 1 uppercase letter" & @CRLF & _
" .* # 0+ chars other than a newline" & @CRLF & _
" )" & @CRLF & _
"$ # string end"
Local $sString = "AAAAAAaa" & @CRLF & _
"AAaaAAaaAVA"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")