use strict;
my $str = 'AAAAAAaa
AAaaAAaaAVA';
my $regex = qr/^ # String start
(?=.{8,}$) # 8 or more characters other than a newline
(?:
[^A-Z\n]*[A-Z][^A-Z\n]* # a string with 1 uppercase letter only
| # or...
(?:[^A-Z\n]*[A-Z]){6} # 6 occ. of 0+ chars other than uppercase letters followed with 1 uppercase letter
.* # 0+ chars other than a newline
)
$ # string end/mxp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}