// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?mx)^ # String start
(?=.{8,}$) # 8 or more characters other than a newline
(?:
[^A-Z\n]*[A-Z][^A-Z\n]* # a string with 1 uppercase letter only
| # or...
(?:[^A-Z\n]*[A-Z]){6} # 6 occ. of 0+ chars other than uppercase letters followed with 1 uppercase letter
.* # 0+ chars other than a newline
)
$ # string end").unwrap();
let string = "AAAAAAaa
AAaaAAaaAVA";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}