import Foundation
let pattern = #"(".*?")|""#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
title:"no spacing before" and text breaks "
title:"no spacing before" and text breaks " after this
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\1"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)