const regex = /^[a-zA-Z](?:\.[A-Za-z0-9._]|[A-Za-z0-9_-]|)+\.?@[A-Za-z0-9]+\.[A-Za-z]{2,6}\b/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^[a-zA-Z](?:\\.[A-Za-z0-9._]|[A-Za-z0-9_-]|)+\\.?@[A-Za-z0-9]+\\.[A-Za-z]{2,6}\\b', 'gm')
const str = `test@gmail.com
w-d@sdf.com
w.d@sdf.com
w.-d@sdf.com
w-d.@sdfcom`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}