use strict;
my $str = 'test@gmail.com
w-d@sdf.com
w.d@sdf.com
w.-d@sdf.com
w-d.@sdfcom';
my $regex = qr/^[a-zA-Z](?:\.[A-Za-z0-9._]|[A-Za-z0-9_-]|)+\.?@[A-Za-z0-9]+\.[A-Za-z]{2,6}\b/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}