re = /cause \(.*?(\d+)\)/m
str = '05/19/2014, 15:24:14.455> LVL:2 RC: 0 SERVER :server main: TERA_MGMT_SYS_SESS_EVENT_RESET with disconnect cause (0x105)'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end