using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=\s|^)(?:\d{1,3}(?:,\d{3})*(?:\.\d+)?|\d{1,3}(?:.\d{3})*(?:\,\d+)?)(?=\s|$)";
string input = @"999,999.99
99,999.22
999.999,99
999.999.23,21
99.999,22
13342,4234,123.23
999,222.334552
9,234.24
2,1
111,22.113
1,3
111";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}