re = /(?<=\s|^)(?:\d{1,3}(?:,\d{3})*(?:\.\d+)?|\d{1,3}(?:.\d{3})*(?:\,\d+)?)(?=\s|$)/m
str = '999,999.99
99,999.22
999.999,99
999.999.23,21
99.999,22
13342,4234,123.23
999,222.334552
9,234.24
2,1
111,22.113
1,3
111'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end