import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "([A-Z][\\w\\-]+ )?\\((\\D*\\d{4}(: ?[\\d\\-]*)*(, \\d{4}(: ?[\\d\\-]*)*)*;?)*\\)";
final String string = "Graham (Doe 2016:45, 2012; Graham 2012, 2014:676-678; Smith 2008) writes that ...";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}