const regex = /([A-Z][\w\-]+ )?\((\D*\d{4}(: ?[\d\-]*)*(, \d{4}(: ?[\d\-]*)*)*;?)*\)/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('([A-Z][\\w\\-]+ )?\\((\\D*\\d{4}(: ?[\\d\\-]*)*(, \\d{4}(: ?[\\d\\-]*)*)*;?)*\\)', '')
const str = `Graham (Doe 2016:45, 2012; Graham 2012, 2014:676-678; Smith 2008) writes that ...`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}