re = /([A-Z][\w\-]+ )?\((\D*\d{4}(: ?[\d\-]*)*(, \d{4}(: ?[\d\-]*)*)*;?)*\)/
str = 'Graham (Doe 2016:45, 2012; Graham 2012, 2014:676-678; Smith 2008) writes that ...'
# Print the match result
str.match(re) do |match|
puts match.to_s
end