using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(.*?)\.*: (.+)";
string input = @"domain.............: iltalehti.fi
status.............: Registered
>>> Last update of WHOIS database: 22.3.2020 11:30:05 (EET) <<<";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}