using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(UNION) S";
string input = @"SELECT * FROM Tabelle1 UNION ALL SELECT * FROM Tabelle2 UNION SELECT * FROM Tabelle3";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}