package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(UNION) S`)
var str = `SELECT * FROM Tabelle1 UNION ALL SELECT * FROM Tabelle2 UNION SELECT * FROM Tabelle3`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}