using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^$|^([\w\d\._%-\\\\\+]+@[\w\d\.-]+\.[\w]+,?)*$";
string input = @"rrbad&am@gmail.com";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}