re = /^$|^([\w\d\._%-\\\\\+]+@[\w\d\.-]+\.[\w]+,?)*$/
str = 'rrbad&am@gmail.com'
# Print the match result
str.match(re) do |match|
puts match.to_s
end