package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^$|^([\w\d\._%-\\\\\+]+@[\w\d\.-]+\.[\w]+,?)*$`)
var str = `rrbad&am@gmail.com`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}