const regex = /[:;)(?!]|(<!\d)[,.]|[,.](?!\d)/gi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[:;)(?!]|(<!\\d)[,.]|[,.](?!\\d)', 'gi')
const str = `one two 1.57 300, 3,123.45 eight. Sentence two is 2.45 degrees. This is a phrase, and so is this.`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}