re = /[:;)(?!]|(<!\d)[,.]|[,.](?!\d)/i
str = 'one two 1.57 300, 3,123.45 eight. Sentence two is 2.45 degrees. This is a phrase, and so is this.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end