$re = '/[:;)(?!]|(<!\d)[,.]|[,.](?!\d)/i';
$str = 'one two 1.57 300, 3,123.45 eight. Sentence two is 2.45 degrees. This is a phrase, and so is this.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);