#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "\[([A-Za-z_]+[^\ \]]+)"
Local $sString = "[yt] Крутое видео[/yt] на сайте!!!! [CDATAKJHKHJ KJHKJHK] Крутое видео[/youtube] на сайте!!!! [code jhg jhg jhgjh jhg jhgjh gj] тут текст арвлаорпл ва[/code] "
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")