$re = '/\[([A-Za-z_]+[^\ \]]+)/';
$str = '[yt] Крутое видео[/yt] на сайте!!!! [CDATAKJHKHJ KJHKJHK] Крутое видео[/youtube] на сайте!!!! [code jhg jhg jhgjh jhg jhgjh gj] тут текст арвлаорпл ва[/code] ';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);