using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"""\b[^""\n]*\b""|\S+";
string input = @"sdfj ""sdfjjk
sdfj ""sdfjjk"" ""sdfjjk
""sdfjjk sdfj ""sdfjjk"" ";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}