package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`"\b[^"\n]*\b"|\S+`)
var str = `sdfj "sdfjjk
sdfj "sdfjjk" "sdfjjk
"sdfjjk sdfj "sdfjjk" `
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}